El Ingesor

El INGEniero profeSOR

Tutoriales

Comandos básicos de configuración de router Cisco (paso a paso)

Esta publicación no es un tutorial exhaustivo sobre los routers Cisco y cómo configurar sus numerosas funciones. Es una guía paso a paso para los comandos de configuración más básicos necesarios para que el router funcione.

Cuando enciende por primera vez un nuevo router Cisco, tiene la opción de usar la utilidad de “configuración” que le permite crear una configuración inicial básica. Sin embargo, en esta publicación le mostraremos cómo hacer esta configuración básica con la interfaz de línea de comandos ( CLI ).

Dominar la CLI de Cisco es esencial para tareas de configuración más complejas y es el conocimiento más importante que debe adquirir si desea convertirse en un administrador de red de Cisco.

Modos de configuración de CLI

Los modos básicos de CLI a los que nos referiremos a continuación son los siguientes:

Router>   — Modo EXEC de usuario —
Router#   
— Modo EXEC privilegiado —
Router(config)#  
— Modo de configuración global —
Router(config-if)#   
— Modo de configuración de la interfaz —
Router(config-line)#   
— Modo de configuración de línea —

Suponemos que ya tiene algunos conocimientos básicos de CLI y cómo navegar entre diferentes modos de configuración (modo de usuario, modo de ejecución privilegiado, etc.), así que comencemos:

Configuración paso a paso de routers Cisco

Paso 1 : Configurar las contraseñas de acceso

El primer paso es asegurar su acceso al router configurando una contraseña secreta global y también contraseñas para Telnet o Console según sea necesario.

Router# configure terminal — Modo EXEC privilegiado —
Router(config)# — Modo de configuración global —

En el modo de configuración global, configura parámetros que afectan a todo el dispositivo router. Aquí configuraremos la contraseña enable secret que usará desde ahora para ingresar al Modo EXEC privilegiado desde el Modo EXEC de usuario.

Router(config)# enable secret “algunacontraseñafuerte”

A partir de ahora, cuando inicie sesión desde el modo EXEC del usuario, se le pedirá una contraseña.

 

También se sugiere configurar una contraseña para las líneas Telnet (líneas VTY) que asegurarán su acceso cuando se conecte a través de Telnet a través de la red.

Router(config)# line vty 0 4
Router(config-line)# password “strongTelnetPassword”
Router(config-line)# login

Paso 2 : Configurar un nombre de host del router

Para diferenciar su router de otros dispositivos en la red, debe configurar un nombre de host para su dispositivo.

Router(config)# hostname Mi-Router
Mi-Router(config)#

Observe que el indicador de su router cambia al nuevo nombre de host que acaba de configurar.

Paso 3 : Configure las direcciones IP para las interfaces del router

Este es un paso esencial para que su router pueda reenviar paquetes en la red. El parámetro más básico para una interfaz de router es la dirección IP. Desde el modo de configuración global, debe ingresar al modo de configuración de la interfaz:

Mi-Router(config)# interface Serial 0/1/0 
Mi-Router(config-if)# ip address 100.100.100.1 255.255.255.252
Mi-Router(config-if)# no shutdown
Mi-Router(config-if)# exit
Mi-Router(config)# interface GigabitEthernet 0/0/0 
Mi-Router(config-if)# ip address 192.168.10.1 255.255.255.0
Mi-Router(config-if)# no shutdown
Mi-Router(config-if)# exit

Paso 4 : Configurar el enrutamiento (estático o dinámico)

El propósito principal del router es encontrar la mejor ruta de ruta hacia una red de destino y reenviar paquetes de acuerdo con la mejor ruta.

Hay dos formas principales en que un router sabe a dónde enviar paquetes. El administrador puede asignar rutas estáticas o el router puede aprender rutas utilizando un protocolo de enrutamiento dinámico.

Para topologías de red simples, se prefiere el enrutamiento estático sobre el enrutamiento dinámico.

Veamos cómo configurar rutas estáticas desde el modo de configuración global.

Mi-Router(config)# ip route [red de destino] [máscara de subred] [puerta de enlace]
Mi-Router(config)# ip route 200.200.200.0 255.255.255.0 100.100.100.2

El comando anterior le dice al router que la red 200.200.200.0/24 es accesible a través de la dirección de puerta de enlace 100.100.100.2.

Otra ruta estática popular que generalmente configuramos en los routers de borde de Internet es la ruta estática predeterminada:

Mi-Router(config) # ip route 0.0.0.0 0.0.0.0 50.50.50.1

La ruta estática predeterminada anterior indica al router que envíe TODOS los paquetes que el router no tiene una entrada de ruta más específica a la dirección de la puerta de enlace 50.50.50.1 (que podría ser la dirección de la puerta de enlace del ISP).

Paso 5 : Guarde su configuración

Guarde su configuración actual en ejecución en NVRAM. Esto sobrescribirá la configuración de inicio.

Mi-Router(config)# exit
Mi-Router# copy running-config startup-config

Puede mostrar su configuración actual para verificar su configuración de la siguiente manera:

Mi-Router # show running-config

Archivos fuente

Descargar escenario

Descargar solución